Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 05, 2025 - 18:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 05, 2025 - 17:06 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 29, 2025 - 16:00 UTC
Scheduled
US2 will be migrating Sep 5 beginning at 11am EDT. Aconex will not be available during this time until Monday, Sep 8 6am EDT.
Note: non-SSO users will need to change their passwords to meet enhanced security requirements. It is recommended that non-SSO users change their passwords before the migration
To reset your password, click the “Forgotten your login name or password?” link located below the login button on the login page.
Passwords must be 15 - 100 characters, with minimum of 8 characters different from the current password, and of 4 different types: capitals, lowercase, numbers, symbols.